发帖    主题    评论    推荐    标签    作者    订阅    查搜    注册   登陆   关注
 
面向对象 设计模式 领域驱动设计 企业架构 框架 开发教程 微服务 大数据 扩展性 并发编程 事件驱动 分布式 SOA
1 2 下一页 Go 2

导入jive论坛的sql表时出现错误!?

2007-09-04 20:50
赞助商链接

今天刚想jive论坛 在导入dll目录下的sql文件时,开始两个都成功了@到mysql—auth。sql时就出错了!显示error 1046
you have an error in your sql syntax;check the manual that corresponds to your Mysql server version for the right syntax to use near '<authentication>
<login-module code = "org.jboss.security.auth.spi.DatabaseServerLoginModule" at line 1
说是我的Mysql版本的事 mysql是5.0的版本!
请banq老师看看怎么解决!



2007-09-05 15:52

这是mysql授权,登入mysql,键入:

GRANT ALL PRIVILEGES ON *.* TO banq@127.0.0.1 IDENTIFIED BY 'xxx' WITH GRANT OPTION;

GRANT ALL PRIVILEGES ON *.* TO banq@locahost IDENTIFIED BY 'xxx' WITH GRANT OPTION;

banq和xxx是用户名和密码,以后牛就使用这个访问MYSQL

2007-09-05 20:13

banq
老师 我是之前在您的安装文档里就跟着这步走的,我已经给banq/用户足够的授权了!而且前面两个mysql—user.sql mysql_forum.sql可以倒进去!!要不我再授权一次看看!

2007-09-06 20:27

彭老师!我用的是mysql5.0版本 运行SimpleJdonFrameworkTest可以,在导入jive的sql时像mysql_forum.sql和mysql_user.sql时是成功导入的!但是在导入mysql_auth.sql才出现上面的错误,所以我觉得是不是mysql的版本过高呢,那段语句“<authentication>
<login-module code = "org.jboss.security.auth.spi.DatabaseServerLoginModule" at line 1”
是否需要更改方可以导入呢!?还是自己手动建表,但是这段安全授权怎么办!?
难道非要换mysql的版本!!

2007-09-23 14:30

我的也是,我把mysql_auth.sql上面的授权部分去掉(怎么看也不像sql语句)
结果。。。。现在登录不上去
mysql_auth.sql是不是有问题,怀疑中。。。
请banq指教

2Go 1 2 下一页

赞助商链接

赞助商链接

返回顶部

移动版 关于本站 使用帮助 联系管理员 最佳分辨率1366x768
OpenSource JIVEJDON Powered by JdonFramework Code © 2002-20 jdon.com