发帖    主题    评论    推荐    标签    作者    订阅    查搜    注册   登陆   关注
 
面向对象 设计模式 领域驱动设计 企业架构 框架 开发教程 微服务 大数据 扩展性 并发编程 事件驱动 分布式 SOA

一个初级问题,关于sun的petshop和jmx的历程

2003-10-07 21:51
赞助商链接

一个很基本的问题,就是在安装这些例程的过程中出现的。
1,安装petshop的时候,按照她的步骤,需要在环境变量里指定java_home和j2ee-home的路径,由于我的jdk是新下载的j2sd和netbeans集成的版本,所以安装目录是C:\Program Files\j2sdk_nb\j2sdk1.4.2
结果发现,petshop的setup.bat执行出错,说c:\progra...无效的命令?后来我按照bat里面的顺序手动执行,发现到最后的命令
set ANT_CLASSPATH=%J2EE_HOME%/lib/j2ee.jar;%ANT_CLASSPATH%
%JAVA_HOME%\bin\java -classpath "%ANT_CLASSPATH%" -Dant.home=%ANT_HOME% -Dj2ee.home=%J2EE_HOME% -Dj2ee-script-suffix=.bat org.apache.tools.ant.Main -buildfile setup.xml %1 %2 %3 %4
无法正确执行,出错信息一堆。。不明白
2,在jmx的例程中,也是在安装环节,编译StandardMBean
下*.java。发现StandardAgent.java无法编译通过,其他没问题
而这个文件的错误信息是,找不到javax.management包,这个包毫无疑问是存在的,而且我将路径信息放入了环境变亮的classpath。甚至手动把那2个。jar文件放到了StandardMBean以下,仍然无法通过编译
我知道这些都是些基本的问题,但是是在惭愧,希望个未能指点一二,谢谢

2003-10-09 11:16

我开始用J2EE1.4也不能正确编译,换回J2EE1.3就OK了。

2003-10-10 20:47

我的JMX。DOC里面要求的就是JDK1.4 啊。。petshop倒是解决了。。和安装路经有关

2003-10-11 16:45

我将example的路径也设进classpath。copy两个.jar进目录。
然后使用这个命令格式
javac -classpath jmxri.jar ;jmxtools.jar *.java编译通过了。但是无法运行 阿。。崩溃

赞助商链接

赞助商链接

返回顶部

移动版 关于本站 使用帮助 联系管理员 最佳分辨率1366x768
OpenSource JIVEJDON Powered by JdonFramework Code © 2002-20 jdon.com