安装Tomcat 5 出现Invalid index!错误求救

03-11-11 midea0978
[ERROR] Digester - -Begin event threw error <java.lang.ExceptionInInitializerErr

or>java.lang.ExceptionInInitializerError: sun.misc.InvalidJarIndexException: Invalid index!

at sun.misc.URLClassPath$JarLoader.getResource(URLClassPath.java:594)

at sun.misc.URLClassPath.getResource(URLClassPath.java:134)

at java.net.URLClassLoader$2.run(URLClassLoader.java:349)

at java.security.AccessController.doPrivileged(Native Method)

at java.net.URLClassLoader.findResource(URLClassLoader.java:346)

at org.apache.catalina.loader.StandardClassLoader.findResource(StandardC

lassLoader.java:562)

at org.apache.catalina.loader.StandardClassLoader.getResource(StandardCl

assLoader.java:638)

at org.apache.commons.modeler.Registry.loadDescriptors(Registry.java:895

)

at org.apache.catalina.mbeans.MBeanUtils.createRegistry(MBeanUtils.java:

1649)

at org.apache.catalina.mbeans.MBeanUtils.<clinit>(MBeanUtils.java:154)

at org.apache.catalina.mbeans.GlobalResourcesLifecycleListener.<clinit>(

GlobalResourcesLifecycleListener.java:112)

at java.lang.Class.newInstance0(Native Method)

at java.lang.Class.newInstance(Class.java:237)

at org.apache.commons.digester.ObjectCreateRule.begin(ObjectCreateRule.j

ava:253)

at org.apache.commons.digester.Rule.begin(Rule.java:200)

at org.apache.commons.digester.Digester.startElement(Digester.java:1273)

at org.apache.xerces.parsers.AbstractSAXParser.startElement(Unknown Sour

ce)

at org.apache.xerces.parsers.AbstractXMLDocumentParser.emptyElement(Unkn

own Source)

at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanStartElemen

t(Unknown Source)

at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl$FragmentContent

Dispatcher.dispatch(Unknown Source)

at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanDocument(Un

known Source)

at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)

at org.apache.xerces.parsers.DTDConfiguration.parse(Unknown Source)

at org.apache.xerces.parsers.XMLParser.parse(Unknown Source)

at org.apache.xerces.parsers.AbstractSAXParser.parse(Unknown Source)

at org.apache.commons.digester.Digester.parse(Digester.java:1548)

at org.apache.catalina.startup.Catalina.load(Catalina.java:514)

at org.apache.catalina.startup.Catalina.load(Catalina.java:552)

at java.lang.reflect.Method.invoke(Native Method)

at org.apache.catalina.startup.Bootstrap.load(Bootstrap.java:260)

at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:396)

那位遇到过这样的情况?

midea0978
2003-11-12 08:36
经过多次尝试,发现我安装的Jdk1.3版本不兼容,升级到jdk1.4之后就正常了.

猜你喜欢