jboss+jetty下的struts问题

04-05-28 huzhigang
本人使用jboss3.2.X+jetty4.X开发struts程序时,出现java.lang.LinkError错误,经长时间检查未发现应用程序的错误.后来在没办法的情况下将程序部署到jboss3.2.X+tomcat下的时候发现没有任何错误.请知道的人帮忙解释一下!难道是jetty本身的问题?

banq
2004-05-28 09:32
这是两个系统动态加载包的机制不一样,你的部署包正好击中Jboss+jetty问题,将struts包拷贝到server/default/lib下,这样部署包不必带struts驱动包

huzhigang
2004-05-28 10:23
多谢.确实没想到jboss的两个版本在类加载方面有不同.我会寻找资料来搞清楚原因的.如果benq老大知道哪里有资料请告诉一下url.

猜你喜欢