mysql驱动程序问题(安装配置jive时碰到的):能否同时存在多个驱动程序呢,端口冲突了?

04-12-18 xfchen
我之前jsp连接mysql用的是sun.jdbc.odbc.JdbcOdbcDriver

现在需要用到

org.gjt.mm.mysql.Driver

可是老是连接失败

日志文件说

Is there a server running on localhost:3306?

应该就是说明端口相冲突了吧

怎么办呢

是在安装配置jive的时候出现的问题

第一步:

Jive 论坛安装工具

欢迎使用Jive论坛!

--------------------------------------------------------------------------------

在安装继续进行前,你的服务器环境必须通过以下所有检查:

安装工具检测到你正运行在 Apache Tomcat/5.0.29上

你的JDK版本为1.2或者更新。

你的应用服务器支持servlet 2.2或者更新。

所有的应用程序包都安装正确。

支持中文检索的lucene包安装正确。

Jive论坛内核 (jive.jar)

文本搜索引擎Lucene (lucene.jar)(中文支持)

JavaMail和NNTP支持 (mail.jar, activation.jar, nntp.jar)

JDBC 2.0 扩展 (jdbc2_0-stdext.jar)

jiveHome 目录正确配置于: c:\Tomcat5.0\webapps\jive\WEB-INF\jiveHome.

第二步:

语言设置

--------------------------------------------------------------------------------

请选择一个你希望Jive使用的语言。以后你可以使用管理工具随时修改语言设置。

English (更多语言增加中)

--------------------------------------------------------------------------------

第三步就不行了:

数据库连接设置

--------------------------------------------------------------------------------

Jive需要使用数据库完成其功能。请填写以下各项完成数据库连接需要的数据。 注意:你应该已经使用数据库安装脚本晚上数据库的建立工作。

driver

driver org.gjt.mm.mysql.Driver

serverURL

serverURL jdbc:mysql://localhost:3306/jive

username

username root

password

password root

minConnections

minConnections 3

maxConnections

maxConnections 10

connectionTimeout

connectionTimeout 0.5

显示这样的错误:

数据库连接设置

--------------------------------------------------------------------------------

Jive需要使用数据库完成其功能。请填写以下各项完成数据库连接需要的数据。 注意:你应该已经使用数据库安装脚本晚上数据库的建立工作。

数据库连接不能建立。打开日志文件"jiveHome\logs\DefaultConnectionProvider.log" 查看错误信息然后返回修正错误。

我查看日志文件

就像上面我说的那样子

是不是端口有冲突了呢

已经有那个

sun.jdbc.odbc.JdbcOdbcDriver

占用了3306端口

所以这个

org.gjt.mm.mysql.Driver

没法连接呢

又急又烦啊

一剑封喉
2004-12-20 17:19
看你的错误提示

好像是mysql服务器没有启动吧

xfchen
2004-12-20 22:01
应该不会的吧

我用sun.jdbc.odbc.JdbcOdbcDriver都可以调用的

不过得odbc数据源里面添加

用这个的话

就不知道该怎么办了啊

是不是还得做一些其他的配置呢

开始以为一样得在odbc数据源添加

可是发现没法添加数据库啊

一剑封喉
2004-12-21 21:59
怎么应该没有啊

你察看以下不就知道了

我用的不是驱动sun.jdbc.odbc.JdbcOdbcDriver

不过那个配置叶挺繁的,也是最容易出错的

xfchen
2004-12-22 10:33
哎呀

似乎都没有看清楚我的意思

怪我没说清楚

也罢了

现在有新的疑问了

我的运行环境是

j2sdk1.4.2,Tomcat5.0,mysql4.1.7

之前我用sun.jdbc.odbc.JdbcOdbcDriver在数据源配置

都可以正常运行调用mysql

昨天我下了个mysql-connector-java-3.1.5-gamma-bin.jar

(com.mysql.jdbc.Driver)

改个程序测试也可以正常运行调用数据库

所以我现在怀疑是不是

mm.mysql-2.0.14-bin.jar(org.gjt.mm.mysql.Driver)版本太低了

准备下个高点的版本试试

高手们怎么看呢

给点意见

猜你喜欢