请教彭老师:开发工具使用的问题

    
yekongda
07-01-10 5 311

希望彭老师及诸位老大为小弟推荐下
eclipse jboss jbosside lomboz mysql 这些工具哪个版本搭配在一起最稳定,各位老大在开发项目中都用什么版本的。
谢谢!

banq
2007-01-10 17:53

我现在使用eclipse3.2.1 jbosside-Beta 2.0
eclipse3.2.1的跟踪单点调试非常不错,JiveJdon3.0这样跨struts+Jdonframework的复杂项目都可以跟踪,再结合log日志,对于琐碎小功能很快能解决。

Lomoz太重,个人不喜欢,当然 它有除JBoss其他EJB2服务器如Weblogic结合

EJB3和JdonFramework编写都无需插件plug-in,如果在使用一个框架之前,插件学习就学习半天,这个框架不算复杂,我真不知道什么叫复杂了和重量了。

使用Struts更无需插件,特别需要XML/JSP的标签提醒,这个JBossIDE也有,以前只有Lomboz有,Eclipse 3.2.1重标签提示是alt+/ 了,不是以前ctrl+space ,为这个改变,曾经让我好郁闷。

Hibernate也无需插件,Hibernate的配置都在Model代码里使用元注释写了,Hibernate千万别用那些数据表导入插件,这些使你走上错误开发方向,围绕数据表的多层结构,实际是伪结构,极其虚伪。一定要是围绕Model的DDD领域模型的面向对象的多层结构。这个问题在本站讨论很多,转变起来难,但必须转,否则使用OO技术做非OO的事情,就象扛着汽车走路一样。

我以前说过,Eclipse是一个很Open的工具,正如老子说的:江海所以能为百谷王者,以其善下之,故能为百谷王,Eclipse之所以为IDE之王,是因为其自由开放,如水无形,但是很容易遭到强势工具的挟持,最终被带离自由开放的广场,走向这些强势工具偏僻小路,后果可想而知。

所以 ,使用Eclipse少用插件,自己加入jar,自己写些简单配置,不喜欢配置用JDK5.0的元注释,代码和配置自己做出来,复杂后出问题才能立即定位,否则调试问题大得很。少用插件特别是如myeclipse之类,更不可采用。

以上个人实践所得,仅供参考。

grokyao
2007-01-10 19:05

我初进java大门,单单使用eclipse,如何做到开发各种系统,不使用myeclipse如何开发 web等呢?请明示!!

wangyu1221
2007-01-10 21:03

为什么不能用myeclipse?

yekongda
2007-01-11 09:06

谢谢彭老师在百忙中抽出时间回答小弟的问题!

2Go 1 2 下一页