请教一下banq大大,关于SPRING配置文件格式出错

adviceid
07-05-28 1 150


当我装载这样的 bean.xml没有任何问题:
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE beans PUBLIC "-//SPRING//DTD BEAN//EN" "http://www.springframework.org/dtd/spring-beans.dtd">
<beans>
.........许多的bean
</beans>

当我装载这样的 bean.xml却抛出 Document root element "beans", must match DOCTYPE root "null" 异常:
<?xml version="1.0" encoding="UTF-8"?>
<beans xmlns="http://www.springframework.org/schema/beans"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns:aop="http://www.springframework.org/schema/aop"
xmlns:tx="http://www.springframework.org/schema/tx"
xsi:schemaLocation="
http://www.springframework.org/schema/beans http://www.springframework.org/schema/beans/spring-beans.xsd
http://www.springframework.org/schema/tx http://www.springframework.org/schema/tx/spring-tx.xsd

http://www.springframework.org/schema/aop http://www.springframework.org/schema/aop/spring-aop.xsd">

.....
</beans>
是不是我缺少了某个LIB包???

adviceid
2007-05-29 16:07

dddd