webshere6.0 jdom包冲突解决办法

09-09-03 vvvvv
各位大哥:帮小弟想想办法,系统发布到websphere上面报错 jdom不兼容 程序用的是jdom1.0 webshphere的lib包有个jdom的0.7版本的 冲突了。我现在是删除webshphere的lib下的jdom就可以了。但是客户不允许删除。请问有什么好的办法。覆盖新的也没用。

vvvvv
2009-09-03 13:14
可以了,覆盖就可以,或者放到lib里的ext目录下面。是我搞错了,少加了一个包。

wlmouse
2009-09-04 20:29
WebSphere里面IBM原装的东西不要乱动,动坏了可麻烦。更改应用的类加载器模式就可以了。WebSphere的加载器分两种。一个是优先使用服务器提供的公共lib,一个是优先使用应用本身的lib。修改一下应用配置就可以了。

猜你喜欢