安装JIVEDON遇到问题了,救助

11-03-17 book007

安装JIVEDON遇到问题了,救助:

不知是否是TOMCAT7.0的问题,选用TOMCAT7.0主要是因为它启动速度比较快。

error见附件的红框。先谢!

近两个星期一直被Tomcat的Error filterStart所困扰,明明运行很好的程序,换了电脑就不能运行了,今天终于发现了问题所在。下面是安装了Tomcat6.0以后得到的错误信息:

2008-1-15 11:10:57 org.apache.catalina.startup.HostConfig deployDirectory

严重: Error deploying web application directory juncsoft

java.lang.UnsupportedClassVersionError: Bad version number in .class file

at java.lang.ClassLoader.defineClass1(Native Method)

at java.lang.ClassLoader.defineClass(Unknown Source)

at java.security.SecureClassLoader.defineClass(Unknown Source)

原来程序被Eclipse重新编译了,而编译时使用的JRE6.0,所以和Tomcat(5.5)所需要的版本(5.0)不一致。改正方法:在Eclipse的Window-->Preferences设置的Java-->Installed JREs中选中5.0版本的JDK重新编译程序。再重新启动Tomcat,令人讨厌的Error filterStart终于消失了,又看到了熟悉的程序界面。

---------------

上面的方法做了也无效果,郁闷。。。。。。

[该贴被book007于2011-03-17 12:48修改过]


banq
2011-03-17 13:38

2011年03月17日 12:44 "book007"的内容
java.lang.UnsupportedClassVersionError: Bad version number in .class file ...

版本问题,必须JDK 6版本编译,我用tomcat 7.02运行jivejdon没有问题,当前这个论坛就是tomcat7.02

book007
2011-03-17 16:19

谢谢BANQ老大。。。。。。

liuliu123
2011-05-06 14:45

测试一下哈哈哈哈
attachment:


cmd.txt

liuliu123
2011-05-06 14:52

2011年05月06日 14:45 "@liuliu123"的内容
测试一下哈哈哈哈 ...
哈哈