jbuilder7+weblogic7方面一个很菜的问题

03-04-05 stonebada

我用petstore的waf模块,在jbuilder中新建一个工程,加入一个新的web application

和jsp页面index.jsp(很简单的,只显示一句话);在web.xml中配置好MainServlet,运行

run|run project,显示错误如下:

<2003-4-5 下午10时57分05秒> <Notice> <Management> <141052> <Application Poller started for development server.>

<2003-4-5 下午10时57分06秒> <Error> <HTTP> <101216> <Servlet: "MainServlet" failed to preload on startup in webapp: "zxjapp"

javax.servlet.ServletException

at weblogic.servlet.internal.ServletStubImpl.createServlet(ServletStubImpl.java:912)

at weblogic.servlet.internal.ServletStubImpl.createInstances(ServletStubImpl.java:833)

at weblogic.servlet.internal.ServletStubImpl.prepareServlet(ServletStubImpl.java:773)

at weblogic.servlet.internal.WebAppServletContext.preloadServlet(WebAppServletContext.java:2763)

at weblogic.servlet.internal.WebAppServletContext.preloadServlets(WebAppServletContext.java:2708)

at weblogic.servlet.internal.WebAppServletContext.preloadResources(WebAppServletContext.java:2681)

at weblogic.servlet.internal.HttpServer.preloadResources(HttpServer.java:552)

at weblogic.servlet.internal.WebService.preloadResources(WebService.java:476)

at weblogic.t3.srvr.ServletInitRunner$1.run(ServletInitRunner.java:50)

at weblogic.security.service.SecurityServiceManager.runAs(SecurityServiceManager.java:744)

at weblogic.t3.srvr.ServletInitRunner.run(ServletInitRunner.java:46)

at java.lang.Thread.run(Thread.java:479)

>

<2003-4-5 下午10时57分10秒> <Notice> <WebLogicServer> <000331> <Started WebLogic Admin Server "myserver" for domain "mydomain" running in Development Mode>

<2003-4-5 下午10时57分10秒> <Notice> <WebLogicServer> <000354> <Thread "ListenThread.Default" listening on port 7001>

<2003-4-5 下午10时57分10秒> <Notice> <WebLogicServer> <000354> <Thread "SSLListenThread.Default" listening on port 7002>

<2003-4-5 下午10时57分10秒> <Notice> <WebLogicServer> <000365> <Server state changed to RUNNING>

<2003-4-5 下午10时57分10秒> <Notice> <WebLogicServer> <000360> <Server started in RUNNING mode>

哪位大侠知道问题在哪,如何解决吗?

另外,编译jsp文件时出错,在run|configurations|build|jsp 下把check jsp....选择框去掉则无问题,但在ie中显示时弹出dos框好像是调用javac编译

先在此谢谢!

stonebada
2003-04-08 11:57

求人不如求己,终于自己搞定。我发了几个问题,没人回答我,失望!高手一句话,少花两天功夫,为何不助人乐己呢?