hibernate网站上说2.0.2是用jdk1.4在LINUX上编译的???

03-08-15 uu_snow
hibernate网站上说2.0.2是用jdk1.4在LINUX上编译的

我现在用的是IBM的WEBSPHERE,它只支持到jdk1.3

那我能用hibernate做项目吗?

uu_snow
2003-08-18 12:51
没人用过WEBSPHERE吗?

robbin
2003-08-18 13:23
除了在hbm映射文件中配置order by需要JDK1.4的支持外,其它的都没有问题。

uu_snow
2003-08-18 17:21
也就是说,我不能使用ORDER BY了????????

robbin
2003-08-18 19:20
你用JDK1.3当然可以在HQL里面使用order by了,只不过使用JDK1.4的时候,多了一个可以选择的功能而已,你也可以在hbm的配置的时候指定order by,这样即使你在HQL里面不使用order by,查出来的也会按照hbm的配置order by的。

猜你喜欢